Age | Commit message (Expand) | Author |
2021-12-23 | firmware: Move memcpy/memset mapping to fw_base.S | Anup Patel |
2021-07-27 | firmware: use _fw_start for load address | Xiang W |
2021-07-17 | firmware: Remove the unhelpful alignment codes before fdt relocation | Bin Meng |
2021-07-11 | fw_base: Put data in .data rather than .text | Jessica Clarke |
2021-07-11 | fw_base: Don't mark fw_platform_init as both global and weak | Jessica Clarke |
2021-07-11 | firmware: Minor optimization in _scratch_init() | Bin Meng |
2021-04-05 | firmware: Remove redundant add instruction from trap restore path | Anup Patel |
2021-04-01 | firware: optimize the exception exit code | Xiang W |
2021-03-19 | firmware: Support position independent execution | Vincent Chen |
2021-03-19 | firmware: Use lla to access all global symbols | Vincent Chen |
2021-01-07 | lib: sbi: Introduce sbi_trap_exit() API | Anup Patel |
2020-12-01 | firmware: fw_base: Optimize trap handler for RV32 systems | Anup Patel |
2020-10-18 | firmware: Remove FW_PAYLOAD_FDT_PATH compile-time option | Anup Patel |
2020-10-18 | firmware: Add common FW_FDT_PATH compile-time option | Anup Patel |
2020-08-14 | firmware: fw_base: Improve exception stack setup in trap handler | Anup Patel |
2020-06-05 | firmware: Allow fw_platform_init() to return updated FDT location | Anup Patel |
2020-06-05 | firmware: fw_base: Don't OR forced FW_OPTIONS | Anup Patel |
2020-06-05 | firmware: fw_base: Make builtin DTB available to fw_platform_init() | Anup Patel |
2020-05-18 | firmware: Correct spelling mistakes | Daniel Schaefer |
2020-05-01 | firmware: fw_base: Introduce optional fw_platform_init() | Anup Patel |
2020-05-01 | firmware: fw_base: Remove CSR_MTVEC update check | Charles Papon |
2020-03-28 | lib: sbi_trap: Simplify sbi_trap_handler() API | Anup Patel |
2020-03-19 | include: sbi_platform: Introduce HART index to HART id table | Anup Patel |
2020-03-13 | firmware: fw_base: Optimize _hartid_to_scratch() implementation | Anup Patel |
2020-01-10 | firmware: Fix placement of .align directives | Andreas Schwab |
2019-11-15 | firmware: Add preferred boot HART field in struct fw_dynamic_info | Anup Patel |
2019-11-05 | firmware: Introduce relocation lottery | Anup Patel |
2019-09-30 | lib: Extend sbi_trap_redirect() for hypervisor extension | Anup Patel |
2019-08-13 | firmware: do not use relocated _boot_status before it is valid | Lukas Auer |
2019-08-09 | firmware: Use macro instead of magic number for boot status | Bin Meng |
2019-08-07 | firmware: Fix the loop condition of _wait_relocate_copy_done section | Nylon Chen |
2019-07-01 | firmware: For no relocation skip two stage wait for secondary HARTs | Anup Patel |
2019-06-24 | firmware: Handle overlapping load and link addresses in relocation | Xiang W |
2019-06-17 | firmware: Handle overlapping load and link addresses in relocation | Xiang W |
2019-06-12 | firmware: Relocate when load address is not equal to link address | Anup Patel |
2019-05-10 | firmware: Allow firmwares to provide next mode and options | Anup Patel |
2019-04-04 | firmware: Fix source fdt alignment | Xiang Wang |
2019-03-29 | firmware: Introduce "options" in "struct sbi_scratch" | Bin Meng |
2019-03-14 | firmware: Move scratch setup to _start instead of _start_warm | Atish Patra |
2019-03-10 | lib: Create a sbi_ipi_data structure | Alistair Francis |
2019-03-07 | firmware: Reset all registers and flush icache | Atish Patra |
2019-03-07 | firmware: Add nop to reduce bus traffic. | Atish Patra |
2019-03-07 | Revert "firmware: Add a barrier instruction for wait for boot hart" | Atish Patra |
2019-03-06 | firmware: Reset all the general purpose registers to zero. | Atish Patra |
2019-03-06 | firmware: Ensure the mtvec is updated. | Atish Patra |
2019-03-06 | firmware: Fix a typo | Atish Patra |
2019-03-05 | firmware: Add a barrier instruction for wait for boot hart | Xiang Wang |
2019-03-05 | firmware: Move _boot_hart_done to the data section | Xiang Wang |
2019-02-20 | firmware: Improve low-level trap handler for M-mode to M-mode traps | Anup Patel |
2019-02-14 | firmware: Use CSR_<FOO> instead of <foo> for csr* | Atish Patra |