aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6c71bc3..23d3e13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,7 +7,7 @@ AM_CONFIG_HEADER(config.h)
dnl Determine the host and build type. The target is always a PIC.
AC_CANONICAL_HOST
-AM_INIT_AUTOMAKE(flexloader, 0.02)
+AM_INIT_AUTOMAKE(flexloader, 0.03)
dnl Checks for programs.
AC_PROG_CC
@@ -17,7 +17,14 @@ AC_PROG_INSTALL
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(fcntl.h)
-AM_SYS_POSIX_TERMIOS
+
+dnl Linux kernel
+AC_CHECK_HEADERS(linux/ppdev.h)
+AC_CHECK_HEADERS(linux/parport.h)
+
+dnl FreeBSD kernel
+AC_CHECK_HEADERS(dev/ppbus/ppi.h)
+AC_CHECK_HEADERS(dev/ppbus/ppbconf.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST