aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 50 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8232326
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,50 @@
+dnl Process this file with autoconf to produce a configure script.
+
+dnl Initialization
+AC_INIT(Makefile.am)
+AM_CONFIG_HEADER(config.h)
+
+dnl Determine the host and build type. The target is always a PIC.
+AC_CANONICAL_HOST
+
+AM_INIT_AUTOMAKE(flexloader, 0.01)
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_INSTALL
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(fcntl.h)
+AM_SYS_POSIX_TERMIOS
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_STRUCT_TM
+
+# some extra flags
+CFLAGS="$CFLAGS -Wall -Werror-implicit-function-declaration "
+LDFLAGS="$LDFLAGS"
+
+# pass flags
+AC_SUBST(CFLAGS)
+AC_SUBST(LDFLAGS)
+
+dnl Substitute configuration variables
+AC_OUTPUT(
+Makefile \
+doc/Makefile \
+src/Makefile \
+)
+AC_MSG_RESULT([
+
+fleur-$VERSION is now configured for $canonical_host_type
+
+ Build: $build
+ Host: $host
+ Source directory: $srcdir
+ Installation prefix: $prefix
+ C compiler: $CC $CFLAGS
+
+])