aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAurelien Jarno <aurelien@aurel32.net>2023-04-01 21:53:58 +0200
committerAurelien Jarno <aurelien@aurel32.net>2023-04-01 21:53:58 +0200
commit5730e908d47984aab65b3bcf0925643401e8476b (patch)
treeb3a197a2e5415f679182cbf110087a049048de33 /debian
parent051bf12ec7907e8f88f31bfb92418888a1a3505f (diff)
downloadflexloader-5730e908d47984aab65b3bcf0925643401e8476b.tar.gz
Import flexloader-0.02.tar.gzflexloader-0.02
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control20
-rw-r--r--debian/copyright16
-rw-r--r--debian/docs2
-rwxr-xr-xdebian/rules92
6 files changed, 137 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..689f555
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+flexloader (0.02-1) unstable; urgency=low
+
+ * Initial Debian upload (closes: bug#291308).
+
+ -- Aurelien Jarno <aurelien@aurel32.net> Thu, 20 Jan 2004 00:16:08 +0100
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..da12631
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,20 @@
+Source: flexloader
+Section: electronics
+Priority: extra
+Maintainer: Aurelien Jarno <aurel32@debian.org>
+Build-Depends: debhelper (>> 4.0.0), autotools-dev
+Standards-Version: 3.6.1
+
+Package: flexloader
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: utility to configure SRAM based ALTERA devices
+ flexloader is a small utility to configure SRAM based ALTERA devices.
+ It downloads a code to the device SRAM using an ALTERA ByteBlaster or
+ a compatible JTAG programmer. It dialogs with it through the parallel
+ interface, using parport.
+ .
+ It supports APEX20K, FLEX10K, FLEX6000 and ACEX1K families.
+ .
+ Author: Aurelien Jarno <aurelien@aurel32.net>
+ Homepage: http://flexloader.aurel32.net
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..0a2402a
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,16 @@
+This package was debianized by Aurelien Jarno <aurelien@aurel32.net> on
+Thu, 20 Jan 2004 00:02:08 +0100.
+
+It was downloaded from http://flexloader.aurel32.net
+
+Upstream Author: Aurelien Jarno <aurelien@aurel32.net>
+
+Copyright: Copyright (C) 2005 Aurelien Jarno
+
+License:
+
+"The code, documentation and schematics are copyright (C) 2005 Aurelien Jarno,
+and are distributed under the terms of the GNU General Public License version 2."
+
+On Debian systems, the complete text of the GNU General Public License can
+be found at /usr/share/common-licenses/GPL
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..724e084
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+README
+TODO
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e0dd5bf
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,92 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ -test -r /usr/share/misc/config.sub && \
+ cp -f /usr/share/misc/config.sub admin/config.sub
+ -test -r /usr/share/misc/config.guess && \
+ cp -f /usr/share/misc/config.guess admin/config.guess
+
+ -chmod 755 configure
+ ./configure \
+ --prefix=/usr \
+ --host=$(DEB_HOST_GNU_TYPE) \
+ --build=$(DEB_BUILD_GNU_TYPE) \
+ --mandir=\$${prefix}/share/man \
+ --infodir=\$${prefix}/share/info
+
+ $(MAKE)
+ touch build-stamp
+
+clean: debian-clean
+ dh_clean
+
+debian-clean:
+ dh_testdir
+ -$(MAKE) distclean
+ -rm -f *-stamp
+ -rm -f admin/config.sub admin/config.guess
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Main install.
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/flexloader
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+# dh_installdebconf
+ dh_installdocs
+# dh_installexamples
+ dh_installmenu
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+ dh_installman
+# dh_installinfo
+ dh_installchangelogs ChangeLog
+ dh_link
+ dh_strip
+ dh_compress --exclude=.docbook
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+# dh_perl
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure